Feature #63455

strong and em in rtehtmlarea

Added by Christof Hagedorn about 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2014-11-30
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Is it still necessary in typo3 6.2 to use this workaround to
use strong and em in the rte? :

http://www.typo3lexikon.de/typo3-tutorials/rte/weitere-beispiele/b-und-i-zu-strong-und-em.html


Related issues

Related to TYPO3 Core - Bug #65695: RTE.default.proc.transformBoldAndItalicTags = 1 doesn't remapClosed2015-03-12

Actions
#1

Updated by Riccardo De Contardi over 6 years ago

@Christof Hagedorn I would not call it a "workaround", as <b> and <i> are valid tags both in HTML4, XHTML and HTML5 and can be still used (e.g. if I remember correctly, usually the name of a ship is for tradition written in italic, but this has no particular "emphasized" meaning); it is your precise choice to remap them from b>strong and i>em.
IMHO it should be not changed, of course it is just my opinion

#2

Updated by Riccardo De Contardi about 6 years ago

  • Tracker changed from Bug to Feature
  • Category set to RTE (rtehtmlarea + ckeditor)
#3

Updated by Alexander Opitz over 5 years ago

  • Status changed from New to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF