Bug #63597

Felogin session cookie is destroyed when navigating after login

Added by Robbert V almost 7 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2014-12-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

After login when I open an login protected page, I get redirected to the login screen. My cookie for the felogin session is then destroyed.
In the related issue I mentioned this earlier, there was a fix. But this is then migrated with another issue en sinds then the login problem occurs again.

My configuration:

TYPO3 6.2.7
PHP 5.5.19
MySQL 5.5.x

[FE][checkFeUserPid] = 1
[FE][lockIP] = 4
[FE][loginSecurityLevel] = normal (because RSA had login problems in the past)
[FE][lifetime] = 86400
[FE][sessionDataLifetime] = 86400
[FE][permalogin] = 0


Related issues

Related to TYPO3 Core - Bug #57751: Felogin session not setClosedMarkus Klein2014-04-08

Actions
Related to TYPO3 Core - Bug #65223: FE Session for logged in user lost after emptying session dataClosedMarkus Klein2015-02-23

Actions
Related to TYPO3 Core - Task #55549: Only set FE user cookie if session data or user logged inClosedBenni Mack2014-02-01

Actions
#1

Updated by Markus Klein almost 7 years ago

Can you please test if the issue goes away when setting [FE][lifetime] = 0 ?
(this will make the cookie a session cookie)

#2

Updated by Robbert V almost 7 years ago

Unfortunately this doesn't work. I also tried to set [FE][permalogin] = 1, but this also didn't help.

#3

Updated by Markus Klein almost 7 years ago

This is really hard to track for me then.
Do you have a chance to debug that instance?

#4

Updated by Robbert V over 6 years ago

Still couldn't find where it goes wrong.
Login works but after that de cookie gets deleted bij renewing a page.

In the mean time the TYPO3 version is updated to 6.2.9

#5

Updated by Markus Klein over 6 years ago

We got now got issue #65223. Could it be that you suffer from the same problem? (Login-mode set on the page)

#6

Updated by Markus Dange over 6 years ago

I have a similar problem with my Typo3 6.2.11 website:
Sometimes when users login with fe_login and contribute something to the forum or their profile they are for some unknown reason automatically logged out.
First it seemed to me that only apple users face the problem, however I had to realize that also windows users face the problem. It seems to work a bit better with Firefox than with other browsers, but not always.

My configuration:

TYPO3 6.2.11
PHP 5.4.38
MySQL 5.5.42

[FE][checkFeUserPid] = 1
[FE][lockIP] = 2
[FE][loginSecurityLevel] = normal
[FE][lifetime] = 0
[FE][sessionDataLifetime] = 86400
[FE][permalogin] = 0

I have now for testing set [FE][lifetime] to "86400" instead of "0". Hopefully this will help.
Thank you very much for any help.

#7

Updated by Markus Klein over 6 years ago

Can you reproduce the problem on your machine or does this only happen sporadically?

#8

Updated by Markus Dange over 6 years ago

Unfortunately the problem only happens sporadically.

I have just got this error report again by a user:
"1. Schreibe Antwort im Forum
2. klicke auf Senden
3. Werde ausgeloggt mit Fehlermeldung: Keine Berechtigung
4. Logge mich erneut ein
5. kopiere Antwort aus Zwischenspeicher (bin ja jetzt schlauer icon_wink.gif)
6. klicke auf Senden -> funktioniert
7. gehe zu einer anderen Diskussion
8. Schreibe Antwort
9. klicke auf Senden
10. fliege wieder raus"
The user uses a Mac with Safari or Chrome.

I use Windows 7 with latest Firefox and I have never been outlogged at all after a few hundreds of logins and postings on the website. However there is another report by a windows 8.1 user with Chrome with the same problems.

Thank you very much for your help.

#9

Updated by Susanne Moog over 1 year ago

  • Status changed from New to Needs Feedback

As this issue is quite old: Is this still reproducible with newer TYPO3 versions? There have been quite some changes in those areas since this report.

#10

Updated by Benni Mack over 1 year ago

  • Status changed from Needs Feedback to Closed

Closing this issue due to lack of feedback for 90 days. If you have more feedback, let me know, so I can re-open the issue.

Also available in: Atom PDF