Bug #63913

Allow ContainerViewHelper to load RequireJS modules

Added by Andreas Fernandez over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2014-12-15
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently, it's not possible to load RequireJS modules into a backend container of an extension.


Related issues

Related to TYPO3 Core - Task #64053: Cleanup: Remove now duplicate ContainerViewHelper Closed 2014-12-29

Associated revisions

Revision 1ae9b716 (diff)
Added by Andreas Fernandez over 4 years ago

[FEATURE] Allow ContainerViewHelper to load RequireJS modules

Add $includeRequireJsModules to ContainerViewHelper that loads RequireJS
modules, if given.

Resolves: #63913
Releases: master
Change-Id: Ie8464963eb421eca65c0a3c750920037bcee78bc
Reviewed-on: http://review.typo3.org/35488
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Reviewed-by: Frank Nägler <>
Tested-by: Frank Nägler <>

Revision c298539a (diff)
Added by Andreas Fernandez over 4 years ago

[CLEANUP] Remove superfluous ContainerViewHelper

The ContainerViewHelper in EXT:beuser is removed due to identical
functionality introduced in Ie8464963eb421eca65c0a3c750920037bcee78bc.

Resolves: #64053
Related: #63913
Releases: master
Change-Id: Ic918a090c605a01a63de6b46d45e91fb4a2378e9
Reviewed-on: http://review.typo3.org/35662
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35488

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35488

#3 Updated by Mathias Schreiber over 4 years ago

  • Target version changed from 7.0 to 7.1 (Cleanup)

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35488

#5 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35488

#6 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35488

#7 Updated by Andreas Fernandez over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF