Bug #64447

Missing picture in deactivated horizontal Rows

Added by J. no-lastname-given over 7 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2015-01-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

My Typo3 version: 6.2.9

I detected a bug in content-elements "pictures" and "pictures and text".

If i add some pictures to the content element and deactivate "horizontal rows" then sometimes the last picture is missing in frontend.

Some cases when it happens and when everything is ok:

3 pictures, 2 cols -> missing Picture
4 pictures, 2 cols -> OK
5 pictures, 2 cols -> missing Picture
6 pictures, 2 cols -> OK

3 pictures, 3 cols -> OK
4 pictures, 3 cols -> missing Picture
5 pictures, 3 cols -> OK
6 pictures, 3 cols -> OK
7 pictures, 3 cols -> missing Picture

So i think it is if #pictures divided by #cols has remainder equal 1

Can somebody confirm this?


Files

horizontal-row-pictures-bug.png (40.9 KB) horizontal-row-pictures-bug.png J. no-lastname-given, 2015-01-23 10:49
Archiv.zip (324 KB) Archiv.zip Mathias Schreiber, 2015-01-23 12:23
3cols-one-to-seven-failed.png (24.5 KB) 3cols-one-to-seven-failed.png Testing only with numbers one to seven J. no-lastname-given, 2015-01-23 14:08
3cols-works.png (37.1 KB) 3cols-works.png J. no-lastname-given, 2015-01-23 14:08
4cols-failed.png (23.1 KB) 4cols-failed.png J. no-lastname-given, 2015-01-23 14:08
4cols-failed-source.png (118 KB) 4cols-failed-source.png sourcecode without number-1 J. no-lastname-given, 2015-01-23 14:08
#1

Updated by J. no-lastname-given over 7 years ago

Sorry I forgot to add the screenshot of my configuration

#2

Updated by Mathias Schreiber over 7 years ago

  • File Archiv.zip Archiv.zip added
  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber

Hi J. (that feels a little odd, btw.),

I attached a set of images that make testing very easy.
I can't reproduce the behavior you describe.
Can we be 100% sure this is no CSS error or something?

#3

Updated by J. no-lastname-given over 7 years ago

Very sure it is NO css error because

first: i tested on two independend typoinstallations with completly different designs
second: the missing picture is NOT in the html :-P

Here are my tests with those 9 pictures (sorted descending)

Strangely this time 2 cols worked correctly. (Yes i cleared all caches)

#4

Updated by Riccardo De Contardi about 7 years ago

I can confirm this bug with 6.2.12... and yes, I confirm that with 2 columns only, it works.

I also tried the following combinations:

3 pictures, 3 cols -> OK
4 pictures, 3 cols -> missing image 4
5 pictures, 3 cols -> OK
6 pictures, 3 cols -> OK
7 pictures, 3 cols -> missing picture 7
8 pictures, 3 cols -> OK
9 pictures, 3 cols -> OK

4 pictures, 4 cols -> OK
5 pictures, 4 cols -> missing image 5
6 pictures, 4 cols -> OK, but the images are shown in 3 columns instead of 4
7 pictures, 4 cols -> OK
8 pictures, 4 cols -> OK
9 pictures, 4 cols -> missing image 9

5 pictures, 5 cols -> OK
6 pictures, 5 cols -> missing image 6
7 pictures, 5 cols -> missing images 6,7
8 pictures, 5 cols -> OK, but the images are shown in 4 columns instead of 5
9 pictures, 5 cols -> OK

6 pictures, 6 cols -> OK
7 pictures, 6 cols -> missing image 7
8 pictures, 6 cols -> missing image 7,8
9 pictures, 6 cols -> OK, but the images are shown in 5 columns instead of 6

#5

Updated by Daniel Goerz almost 7 years ago

  • Status changed from Needs Feedback to New
#6

Updated by Riccardo De Contardi over 6 years ago

I made a test with 7.6.1-dev (latest master) and the bug is still present using CSC (Fluid styled content has no "horizontal row" checkbox):

3 pictures, 3 cols -> OK
4 pictures, 3 cols -> missing picture 4
5 pictures, 3 cols -> OK
6 pictures, 3 cols -> OK
7 pictures, 3 cols -> missing picture 7
8 pictures, 3 cols -> OK
9 pictures, 3 cols -> OK

4 pictures, 4 cols -> OK
5 pictures, 4 cols -> missing picture 5
6 pictures, 4 cols -> OK, but the images are shown in 3 columns instead of 4
7 pictures, 4 cols -> OK
8 pictures, 4 cols -> OK
9 pictures, 4 cols -> missing picture 9

5 pictures, 5 cols -> OK
6 pictures, 5 cols -> missing picture 6
7 pictures, 5 cols -> missing pictures 6 and 7
8 pictures, 5 cols -> OK, but the images are shown in 4 columns instead of 5
9 pictures, 5 cols -> OK

6 pictures, 6 cols -> OK
7 pictures, 6 cols -> missing picture 7
8 pictures, 6 cols -> missing pictures 7 and 8
9 pictures, 6 cols -> OK, but the images are shown in 5 columns instead of 6

7 pictures, 7 cols -> OK
8 pictures, 7 cols -> missing picture 8
9 pictures, 7 cols -> missing pictures 8 and 9

8 pictures, 8 cols -> OK
9 pictures, 8 cols -> missing picture 9

#7

Updated by Riccardo De Contardi over 5 years ago

"noCols" has been dropped for CSC,too on 8.6 and above.

#8

Updated by Riccardo De Contardi about 5 years ago

  • Status changed from New to Closed
  • Assignee deleted (Mathias Schreiber)

I close this as version 7.6.x has entered in its "priority bugfix" phase and it will not be fixed.

If you think that this is the wrong decision then please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF