Bug #64574

felogin stdWrap for messages not working in external typoscript files

Added by Riccardo De Contardi over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2015-01-29
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

stdWrap for messages in felogin, like:

plugin.tx_felogin_pi1.errorMessage_stdWrap.wrap = <p class="error-login">|</p>

does not work (the default wrap is used) when the TS code is put in an external file and then loaded with INCLUDE_TYPOSCRIPT like:

<INCLUDE_TYPOSCRIPT: source="FILE:EXT:bhsiteconf/Configuration/TypoScript/Common/setup.felogin.t3s">

If it is put in the setup field of the TS template, it works.

History

#1 Updated by Frederic Gaus over 4 years ago

  • Status changed from New to Needs Feedback

I can not confirm this issue. Works fine here. I guess this has something to do with your personal setup. Could you please provide more information and maybe a screenshot of Web > Template > Template Analyzer?

#2 Updated by Riccardo De Contardi over 4 years ago

Full TS listing is 7933 lines :S should I still post it on a Gist?

#3 Updated by Riccardo De Contardi about 4 years ago

I got where the problem begins using template analyzer:

I write my configuration

<INCLUDE_TYPOSCRIPT: source="FILE:EXT:bhsiteconf/Configuration/TypoScript/Common/setup.felogin.t3s">

inside an extension I built , in the setup.txt file which I load in typoscript as "include static from extension",that is:

TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addStaticFile($_EXTKEY, 'Configuration/TypoScript', 'My Provider extension for pages and content');

in ext_tables.php

please note that in the "include static from extension" it is loaded as the last extension.

in fact, the felogin standard typoscript configuration is loaded AFTER this!!that's why it overwrites mine!

if I write in the TS Setup field of the TS template the same line:

<INCLUDE_TYPOSCRIPT: source="FILE:EXT:bhsiteconf/Configuration/TypoScript/Common/setup.felogin.t3s">

this will be (obviously) loaded as the last!

#4 Updated by Sacha Vorbeck about 4 years ago

It`s the same with indexed search: some old extensions still use the file ext_typoscript setup.txt to include their TS.
The TS should be moved to a ./static/setup.txt file. This way you could override the settings with your own extension.

#5 Updated by Riccardo De Contardi about 4 years ago

I have understood it is not a bug, but a standard behavior due to the old code, so I guess this could be closed;
but will Felogin be updated? Maybe in version 7 will there be a more modern (fluid?) Felogin?

cheers

#6 Updated by Alexander Opitz over 3 years ago

Hi,

are there still questions open on this?

#7 Updated by Riccardo De Contardi over 3 years ago

IMO, this can be closed, as it is not a bug, but the standard (old) behavior.

My only question was if an update of the extension is planned.

#8 Updated by Alexander Opitz over 3 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF