Bug #64654

If a sys_template record has only "basedOn" that were already included, an SQL error is shown

Added by Nils Blattner almost 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
TypoScript
Target version:
Start date:
2015-01-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hi there

Recursive inclusion of templates generates an SQL error, if the (already) included template is the only listed in "basedOn":

  • "base template" includes
    • "content rendering" includes
      • "base template"

Because "content rendering" only has one "basedOn" which is already included before, the SQL generated contains "uid IN ()" and results in an error.
Of course recursion is not desirable, but more complex scenarios can be imagined easily, that also produce this error. If only templates are "basedOn", that are already included previously, the SQL is faulty.

Attached patch would take care of that.

PS: T3 6.2.9

Kind regards
Nils


Files

TemplateService.php.diff (1.8 KB) TemplateService.php.diff Nils Blattner, 2015-01-30 17:16

Also available in: Atom PDF