Bug #64656

Bug #40005: Several unit tests fail under Windows system

Failing unit tests due to wrong path handling

Added by Nicole Cordes about 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Tests
Target version:
Start date:
2015-01-30
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In the TYPO3\CMS\Fluid\Tests\Unit\View\StandaloneViewTest test case multiple tests fail on Windows systems because of wrong directory separator. Within the core classes unix like paths are used but tested agains native Windows paths.

Associated revisions

Revision 4e46236e (diff)
Added by Nicole Cordes about 5 years ago

[BUGFIX] Failing unit tests due to wrong path handling

In some tests of the StandaloneViewTest case the configured expections
aren't met which results in failing tests on Windows systems. The mock
is configured to return values when calling with giving parameter. The
parameter contains the path to a layout root. During runtime the used
paths are converted to unix like paths but the tests are configured to
expect Windows paths (forward slashes vs. backward slashes). This patch
converts paths to unix like paths before the expectations are configured
to not fail on Windows systems.

Releases: master, 6.2
Resolves: #64656
Change-Id: Ie362cc4e2efa41b6cee068e60313c1bfb22340b2
Reviewed-on: http://review.typo3.org/36455
Reviewed-by: Oliver Klee <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision 16277091 (diff)
Added by Nicole Cordes about 5 years ago

[BUGFIX] Failing unit tests due to wrong path handling

In some tests of the StandaloneViewTest case the configured expections
aren't met which results in failing tests on Windows systems. The mock
is configured to return values when calling with giving parameter. The
parameter contains the path to a layout root. During runtime the used
paths are converted to unix like paths but the tests are configured to
expect Windows paths (forward slashes vs. backward slashes). This patch
converts paths to unix like paths before the expectations are configured
to not fail on Windows systems.

Releases: master, 6.2
Resolves: #64656
Change-Id: Ie362cc4e2efa41b6cee068e60313c1bfb22340b2
Reviewed-on: http://review.typo3.org/36458
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36455

#2 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36458

#3 Updated by Nicole Cordes about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Anja Leichsenring about 4 years ago

  • Sprint Focus deleted (On Location Sprint)

#5 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF