Bug #64657

Bug #40005: Several unit tests fail under Windows system

Failing unit test in SqlSchemaMigrationServiceTest on Windows systems

Added by Nicole Cordes over 5 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Tests
Target version:
Start date:
2015-01-30
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The test getFieldDefinitionsFileContentHandlesMultipleWhitespacesInFieldDefinitions fails on Windows systems because the expected and actual array have a different array key for the table name. On run time within the code tables names are set explicit to lower cases.

Associated revisions

Revision 6fa5cef8 (diff)
Added by Nicole Cordes over 5 years ago

[BUGFIX] Failing unit test in SqlSchemaMigrationServiceTest

Currently the test for handling multiple white spaces within the sql
field definitions fails on Windows systems because of a different key
for the table name within the expected and actual array. This is caused
by a strict lowercase converting in the code for Windows systems. As the
table name is irrelevant for the test itself, this patch simply converts
table name to lower case.

Releases: master, 6.2
Resolves: #64657
Change-Id: I8d083e988b9a7403f0ff514af1ebe54adf065383
Reviewed-on: http://review.typo3.org/36459
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision c6b7b272 (diff)
Added by Nicole Cordes over 5 years ago

[BUGFIX] Failing unit test in SqlSchemaMigrationServiceTest

Currently the test for handling multiple white spaces within the sql
field definitions fails on Windows systems because of a different key
for the table name within the expected and actual array. This is caused
by a strict lowercase converting in the code for Windows systems. As the
table name is irrelevant for the test itself, this patch simply converts
table name to lower case.

Releases: master, 6.2
Resolves: #64657
Change-Id: I8d083e988b9a7403f0ff514af1ebe54adf065383
Reviewed-on: http://review.typo3.org/36463
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36459

#2 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36463

#3 Updated by Nicole Cordes over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Anja Leichsenring almost 5 years ago

  • Sprint Focus deleted (On Location Sprint)

#5 Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF