Bug #65488

TimeTracker not set for eID scripts

Added by Mathias Brodala over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Category:
Miscellaneous
Target version:
Start date:
2015-03-03
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

With the recent request handler refactoring some breaking changes where introduced, among others the global TimeTracker $GLOBALS['TT'] not being set for eID scripts anymore:

( ! ) Fatal error: Call to a member function push() on null in /var/www/typo3_src/typo3/sysext/frontend/Classes/Controller/TypoScriptFrontendController.php on line 1206
Call Stack
#    Time    Memory    Function    Location
1    0.0719    240072    {main}( )    .../index.php:0
2    0.0790    639632    TYPO3\CMS\Core\Core\Bootstrap->run( ??? )    .../index.php:33
3    0.1116    2472944    TYPO3\CMS\Frontend\EidRequestHandler->handleRequest( )    .../Bootstrap.php:195
4    0.1249    2482888    require( '/var/www/typo3conf/ext/routing/Classes/Controller/RoutingController.php' )    .../EidRequestHandler.php:61
5    0.2003    2609712    Causal\Routing\Controller\RoutingController->dispatch( )    .../RoutingController.php:332
6    0.2108    2650536    Causal\Routing\Controller\RoutingController->initTSFE( )    .../RoutingController.php:114
7    0.8588    4934936    TYPO3\CMS\Frontend\Controller\TypoScriptFrontendController->determineId( )    .../RoutingController.php:314

Related issues

Related to TYPO3 Core - Task #65437: Introduce proper RequestHandling for all requests Closed 2015-03-01

Associated revisions

Revision 030c5cdd (diff)
Added by Mathias Brodala over 4 years ago

[BUGFIX] Fix access to time tracker in eID scripts

During refactoring of request handling setup of the global time
tracker was removed for eID scripts.

This also fixes the setup order in the frontend request handler
since this happened before the "preprocessRequest" hook was executed
in the old index_ts.php

Resolves: #65488
Releases: master
Change-Id: I5b0c63db37360039fdb9d9e0ff29adfa38da22c5
Reviewed-on: http://review.typo3.org/37503
Reviewed-by: Juan Manuel Vergés Solanas <>
Tested-by: Juan Manuel Vergés Solanas <>
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37503

#2 Updated by Mathias Brodala over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100

#3 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF