Bug #65776

check in Upgrade Wizard fails due to truncated file path

Added by Sybille Peters over 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2015-03-16
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Reproduce

  1. Update from the latest 4.5 to 6.2.10 and run the Upgrade Wizard.

Result

Upgrade Wizard shows a number of links to missing files. Some of these are not actually missing. The problem seems to be that the Upgrade Wizard truncates the path of long filenames (length > 200), the File Abstraction Layer however has no problem with path / filename of this size, so the link actually works. The error message of the Upgrade Wizard is wrong.

More information:

Error message

File not found (page / uid / path / table / field):,3249,30782,fileadmin/sonderpaedagogik/DownloadsDozeten/Luedtke/Luedtke_Kallmeyer_2007_._Sprachenvielfalt_in_deutschen_Kindergaerten_-_Chance_oder_Hindernis._hoergeschaedigte_kinder_-_erwachsene_hoergeschaedigte.,tt_content,bodytext

Name of path:

fileadmin/sonderpaedagogik/DownloadsDozeten/Luedtke/Luedtke_Kallmeyer_2007_._Sprachenvielfalt_in_deutschen_Kindergaerten_-_Chance_oder_Hindernis._hoergeschaedigte_kinder_-_erwachsene_hoergeschaedigte.pdf

Entry in sys_file is correct:

uid=8814, identifier="/sonderpaedagogik/DownloadsDozeten/Luedtke/Luedtke_Kallmeyer_2007_._Sprachenvielfalt_in_deutschen_Kindergaerten_-_Chance_oder_Hindernis._hoergeschaedigte_kinder_-_erwachsene_hoergeschaedigte.pdf" 


Related issues

Related to TYPO3 Core - Story #66138: "Migrate all file links of RTE-enabled fields to FAL" fails with UTF-8-filenames Closed 2015-03-30

History

#1 Updated by Markus Klein over 4 years ago

  • Status changed from New to Needs Feedback

The problem is not the wizard but the refindex.

sys_refindex: ref_string varchar(200) DEFAULT '' NOT NULL,

the string is only saved with up to 200 chars.

You can work around the problem by simply extending this field or changing it to text-datatype in DB of the 4.5 installation.
After that re-run the refindex-update and do the upgrade again.

#2 Updated by Sybille Peters over 4 years ago

Thanks for the workaround. That is very helpful.

I reported it, because I thought it migtht cause problems for othes as well.

#3 Updated by Alexander Opitz over 4 years ago

  • Status changed from Needs Feedback to Closed

Thanks for feedback. Closing as Workaround is possible.

#4 Updated by Sybille Peters almost 2 years ago

  • Description updated (diff)

Also available in: Atom PDF