Bug #66344

Some exceptions contain HTML code

Added by Mathias Brodala over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Code Cleanup
Target version:
Start date:
2015-04-10
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

There are currently 4 exceptions in the core whose messages contain HTML code:

  • RuntimeException in TYPO3\CMS\Backend\Controller\LoginController::checkRedirect
  • RuntimeException in TYPO3\CMS\Backend\Tree\View\AbstractTreeView::getTree
  • RuntimeExceptoin in TYPO3\CMS\Core\Authentication\AbstractUserAuthentication::checkAuthentication
  • ExtensionManagerException in TYPO3\CMS\Extensionmanager\Utility\Connection\TerUtility::fetchExtension

Since exceptions are independent from a specific context, this HTML code should be removed.

Associated revisions

Revision 4f88ab75 (diff)
Added by Mathias Brodala over 4 years ago

[BUGFIX] Remove HTML from exception messages

Exception messages are independent from a specific context and thus
should not contain HTML code.

Resolves: #66344
Releases: master
Change-Id: I8bfab2d1da3fc3baf344d833eaaec8b267732baf
Reviewed-on: http://review.typo3.org/38609
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Mathias Brodala over 4 years ago

The exceptions where found with this RegExp search pattern: new .+Exception\(["'].*?< (false-positives need to be skipped)

#2 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38609

#3 Updated by Anja Leichsenring over 4 years ago

  • Sprint Focus set to Stabilization Sprint

#4 Updated by Mathias Brodala over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100

#5 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF