Bug #66653

shortcut_mode value is not correctly selected when adding translation of a page

Added by Lorenz Ulrich over 5 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2015-04-29
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When a page of type "Shortcut" is translated, the value for the field shortcut_mode is not correctly selected:

This is distracting for editors because they assume that by default a translated page has the same properties as the page in the default language.

shortcut_mode.png View (22.8 KB) Lorenz Ulrich, 2015-04-29 11:37

History

#1 Updated by Lorenz Ulrich over 5 years ago

#2 Updated by Riccardo De Contardi about 5 years ago

It is still present in both 6.2.15 and 7.5-dev (latest master)

Step to reproduce:

1) create a new page > type: shortcut
1.1) set the target to an existing page
1.2) set shortcut mode: "random subpage of selected/current page"
2) click on page > select "languages" on top dropdown > select the language on dropdown "Make new translation of this page:"
RESULT: shortcut mode is "Selected page" (the first one of the dropdown)

#3 Updated by Riccardo De Contardi over 2 years ago

This issue is still present on 8.7.12 but it seems solved on 9.2-dev (latest master) where on both fields Shortcut Mode and Shortcut Target you can choose the "translation behavior" via the radio button Custom value / Value of default language

#4 Updated by Guido Schmechel about 2 years ago

typo3/cms/typo3/sysext/core/Classes/DataHandling/DataHandler.php (8.7.17)
Line 4865

Here is just a simple check for "text" and "input", but for select (and other types) it doesn't exist an else case. If we add e.g. this check it works:

                if ($fCfg['config']['type'] === 'select') {
                    $overrideValues[$fN] = $row[$fN];
                }

=> Version 9 is not affected because pages_language_overlay no longer exists.

#5 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57708

#6 Updated by Gerrit Code Review about 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57720

#7 Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57720

#8 Updated by Gerrit Code Review about 2 years ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57720

#9 Updated by Gerrit Code Review about 2 years ago

Patch set 4 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57720

#10 Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57720

#11 Updated by Susanne Moog over 1 year ago

  • Status changed from Under Review to New

Patch was abandoned.

#12 Updated by Riccardo De Contardi 7 months ago

  • Status changed from New to Closed

This issue is resolved for version 9.5 and higher;

We feel sorry but this issue will not be fixed on version 8.7.x as it is in its "priority bugfix" phase of life, and only security and critical bugfixes will be developed.

If you experience the issue again on newer TYPO3 versions, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF