Bug #66660

Typoscript option "sendCacheHeaders": ETag with extra quotes / ETag not used

Added by Markus no-lastname-given over 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2015-04-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

With the Typoscript-Configuration "config.sendCacheHeaders = 1" several Cache-Headers are activated, ETag being one of them, but it is not working as expected.

- The ETag is sent with extra quotes, i.e. ETag: ""0029b4c9a24477f3b90651f7caa85cf5""
- When a request is made including the request header If-None-Match: ""0029b4c9a24477f3b90651f7caa85cf5"", a HTTP 200 ist sent back along with the content, instead of a 304 as it should be.

#1

Updated by Benni Mack over 5 years ago

  • Status changed from New to Needs Feedback

Hey, I just double-checked.

ETag is working fine for a couple of projects (master and 6.2) - could you please let me know which client / browser and which server (apache / nginx) you are using?

thx.

#2

Updated by Markus no-lastname-given over 5 years ago

I checked it again, Problem is still there for me.

Server:
Apache/2.2.22
PHP: Version 5.4.41-0+deb7u1

Client:
Firefox 38.0.5

#3

Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to New
#4

Updated by Benni Mack over 3 years ago

  • Status changed from New to Needs Feedback

OK. I checked some more things:
- Wikipedia states using ETag with quotes: https://en.wikipedia.org/wiki/HTTP_ETag, the original specification does not state that (I didn't find anything)
- Dmitry added this functionality in 2008 (Issue #10012 but could not find it) due to some "incorrect" behaviour back then
- Chrome does it right, Firefox (current version) adds a double-quote, so that rather goes into "it's a firefox issue"

Can you also check some other browsers?

#5

Updated by Markus no-lastname-given over 3 years ago

The original system I needed the feature for is no longer available to me.
I tried the config setting in current TYPO3 8.7.1, but don't seem to be getting an E-Tag at all now. I don't know if the feature has been removed or I forgot some conflicting setting. :-/

#6

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Needs Feedback to Closed

@Markus no-lastname-given, I am closing your ticket for now;

If you think that this is the wrong decision or experience this issue again, then please reopen it or open a new ticket and add a relation to this ticket number. Thank you!

Also available in: Atom PDF