Bug #66768

TCA not loaded for runtimeActivatedPackages

Added by Nicole Cordes almost 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
System/Bootstrap/Configuration
Target version:
Start date:
2015-05-03
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently you have to clear all caches to use $GLOBALS['TYPO3_CONF_VARS']['EXT']['runtimeActivatedPackages'] because runtime activated packages are not included in the cache identifier. If you remove an extension from config the system breaks because of cached files.


Related issues

Related to TYPO3 Core - Bug #58871: CLI "extension:install" does not work correctly with config "runtimeActivatedPackages" Closed 2014-05-16

Associated revisions

Revision b175e121 (diff)
Added by Nicole Cordes almost 5 years ago

[BUGFIX] Activate runtimeActivatedPackages without cache clearing

Currently you have to clear all caches manually to use runtime activated
packages because they are not included in the building process of the
cache identifier. This patch defines the TYPO3_CONF_VARS setting per
default and includes it in the cache identifier. Furthermore runtime
activated packages are excluded from being disabled in EM.

Release: master, 6.2
Resolves: #66768
Resolves: #58874
Change-Id: Idbda3c4f1f3c827c2b26c6f7759a9121cc260068
Reviewed-on: http://review.typo3.org/39227
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision 1a877f22 (diff)
Added by Nicole Cordes almost 5 years ago

[BUGFIX] Activate runtimeActivatedPackages without cache clearing

Currently you have to clear all caches manually to use runtime activated
packages because they are not included in the building process of the
cache identifier. This patch defines the TYPO3_CONF_VARS setting per
default and includes it in the cache identifier. Furthermore runtime
activated packages are excluded from being disabled in EM.

Release: master, 6.2
Resolves: #66768
Resolves: #58874
Change-Id: Idbda3c4f1f3c827c2b26c6f7759a9121cc260068
Reviewed-on: http://review.typo3.org/39378
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39227

#2 Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39227

#3 Updated by Gerrit Code Review almost 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39227

#4 Updated by Nicole Cordes almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Martin Kutschker almost 5 years ago

Related to issue #58871?

#6 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39378

#7 Updated by Nicole Cordes almost 5 years ago

  • Status changed from Under Review to Resolved

#8 Updated by Anja Leichsenring about 4 years ago

  • Sprint Focus deleted (On Location Sprint)

#9 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF