Bug #66955

Fatal error in EM if composer packages available

Added by Nicole Cordes about 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
System/Bootstrap/Configuration
Target version:
Start date:
2015-05-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Composer packages are initialized as instances of Flow Package not instances of TYPO3.CMS Package. Therefore the PackageManager fails to call the function isPartOfFactoryDefault because this function is only available for TYPO3.CMS Packages.

#1

Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39543

#2

Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39544

#3

Updated by Helmut Hummel about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Anja Leichsenring over 5 years ago

  • Sprint Focus deleted (On Location Sprint)
#5

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF