Feature #67365

Renaming fields from sys_file_metadata doesn't work

Added by Florian Seirer about 6 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2015-06-09
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:
On Location Sprint

Description

I'd like to rename fields like sys_file_metadata.title and sys_file_metadata.alternative in the backend (filelist module), so that my editors get a better understanding of the field's purpose.

This usually works quite well with the pageTS setting

TCEFORM.sys_file_reference.title.label = Titel (für Quelle)
(For file references in content elements, in this case).
But
TCEFORM.sys_file_metadata.title.label = Titel (für Quelle)
doesn't seem to have any effect.

It did work after I put

$TCA['sys_file_metadata']['columns']['title']['label'] = 'Titel (für Quelle)';
in /typo3conf/extTables.php.

Still, is this intended?

#1

Updated by André Spindler about 6 years ago

Hello, in my opinion this is not a bug.

File references have a pid field which is set to the page where the related record (tt_content, news, something else) is located. Using pageTS on Your website root, You can change and override the settings in the references.

But file metadata is stored on pid=0, this means on the TYPO3 root page. You cannot get there using pageTS on pages, as this is always at least one level down.

You can only use file typo3conf/extTables.php here (what You already found out) or create an extension and use "\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addPageTSConfig()" in the ext_localconf.php of Your extension.

#2

Updated by Andreas Keck about 6 years ago

Same requirement here.

Ok André, youre right. It's not a bug, it´s a new feature.

Is it an idea, to create a field TsConfig in file reference like "fileTsconfig". And there you can place several code to operate formatting of filelist with tsconfig.

#3

Updated by Mona Muzaffar about 4 years ago

  • Tracker changed from Bug to Feature
#4

Updated by Benjamin Kott about 4 years ago

  • Sprint Focus set to On Location Sprint
#5

Updated by Mona Muzaffar about 4 years ago

  • Status changed from New to Rejected

this won't be implemented yet because just like andré said the file metadata is stored on pid=0, and pageTS configurations are not meant to modify these global settings.

Also available in: Atom PDF