Bug #67440

Correct typo in code example (ChangeLog files)

Added by Michael Schams about 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Documentation
Target version:
-
Start date:
2015-06-14
Due date:
% Done:

20%

Estimated time:
0.25 h
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

File Feature-66669-BeLoginFormAPI.rst shows the following code example:

$GLOBALS['TYPO3_CONF_VARS']['EXTCONF']['backend']['loginProviders'][1433416020] = [
    'provider' => \TYPO3\CMS\Backend\LoginProvider\UsernamePasswordLoginProvider::class,
    'sorting' => 50,
    'icon-class' => 'fa-key',
    'label' => 'LLL:EXT:backend/Resources/Private/Language/locallang.xlf:login.link'
];

Should not this be:

$GLOBALS['TYPO3_CONF_VARS']['EXTCONF']['backend']['loginProviders'][1433416020] = array(
    [...]
);

If so:

This patch updates the core documentation to correct a typo in the code example.


Related issues

Related to TYPO3 Core - Bug #66669: Possibility to extend/override New login screen Closed 2015-05-16

History

#1 Updated by Gerrit Code Review about 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40232

#2 Updated by Michael Schams about 4 years ago

Note: I understand, that this is not a bug and $variable = [ ... ]; is valid PHP code, but I am not sure, if our Coding Guidelines allow this :-)

#3 Updated by Mathias Schreiber about 4 years ago

  • Status changed from Under Review to Rejected

yes, they are compliant to the CGL.
New code, that is being touched will use the new syntax.

I will remove the review, too.

Also available in: Atom PDF