Project

General

Profile

Actions

Bug #67610

closed

Unable to call TYPO3\CMS\Core\ExtDirect\ExtDirectDebug::__destructor()

Added by Bernd Niehues about 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-06-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I'm using TYPO3 7.3 in nginx, php-fpm (5.6.9) environment.
When trying to render the pagetree in Backend the following error is thrown:
Unable to call TYPO3\CMS\Core\ExtDirect\ExtDirectDebug::__destructor()

To solve you'll need to add

    /**
     * destructor
     *
     * Currently empty, but automatically registered and called during
     * ExtDirect shutdown.
     *
     * @see http://forge.typo3.org/issues/25278
     */
    public function __destructor() {

    }

to the following file:
/typo3/sysext/core/Classes/ExtDirect/ExtDirectDebug.php


Files

PackageStates.php (21 KB) PackageStates.php Bernd Niehues, 2015-06-19 09:14

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #25278: t3lib_extjs_ExtDirectDebug::__destruct() missingClosed2011-03-08

Actions
Actions #1

Updated by Markus Klein about 9 years ago

  • Description updated (diff)
Actions #2

Updated by Markus Klein about 9 years ago

  • Status changed from New to Needs Feedback

Which extensions are you using?

Actions #3

Updated by Bernd Niehues about 9 years ago

Markus Klein wrote:

Which extensions are you using?

Hi Markus, i've just attached my PackagesStates file.

Actions #4

Updated by Markus Klein about 9 years ago

Quite a lot of extensions I must admit.

My first guess is cc_debug.
Otherwise you should disable all non-core extensions one by one.

Actions #5

Updated by Bernd Niehues about 9 years ago

You're right! It's cc_debug. But maybe you can give me a hint what's wrong in cc_debug?
Is it just missing a __destructor method?

Actions #6

Updated by Markus Klein about 9 years ago

I can't remember what the actual issue is/was. I had a similar issue with firedebug back then. I just stopped using it, since there is no need for using this kind of extensions anymore.
Fluid has a debug-viewhelper and the remainder is done via debugging (xdebug). For logging you can use the Logging API, which is far more versatile than any of those pseudo debug extensions.

Actions #7

Updated by Wouter Wolters over 8 years ago

Can we close this ticket?

Actions #8

Updated by Markus Klein over 8 years ago

  • Status changed from Needs Feedback to Closed
  • Complexity deleted (no-brainer)
Actions

Also available in: Atom PDF