Project

General

Profile

Actions

Bug #67671

closed

Logout from Backend throws exception due to malformed URL

Added by Daniel Goerz over 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2015-06-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

Since the refactoring of the User-Box to use fluid, it is no longer possible to logout from the Backend or to switch back to your own user after you switched in the BackenUser module.

The reason is a htmlencoded "&" which is representated as "&" in the URL. So the Module-Token is no longer recognized.

My current logut-URL looks like this:

http://my.core.loc/typo3/mod.php?M=logout&moduleToken=2739b4134abaea55df1c703677d0ac7ff4ab93ca

This URL is produced by the following Code in \TYPO3\CMS\Backend\Backend\ToolbarItems\UserToolbarItem, line 109

htmlspecialchars(BackendUtility::getModuleUrl('logout'))

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #67537: Port toolbar dropdowns to FluidClosed2015-06-17

Actions
Actions #1

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40519

Actions #2

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40519

Actions #3

Updated by Christian Kuhn over 8 years ago

  • Status changed from Under Review to Resolved

The issue that introduces this regression was reverted, this issue is solved.

Actions #4

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF