Bug #68444

t3editor: close autocomplete on backspace

Added by Stefan Froemken almost 6 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
t3editor
Target version:
-
Start date:
2015-07-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello,

page = PAGE
page.10 = CONTENT
page.10.slide.collectReverse.HTMLparser = 1
page.10.[autocomplete is open, now press backspace]

After pressing backspace, autocomplete is still open with a suggestion which is already there. Would be good to have autocomplete closed then.

Stefan

#1

Updated by Wouter Wolters almost 6 years ago

  • Category set to t3editor
#2

Updated by Andreas Fernandez almost 6 years ago

  • Status changed from New to On Hold

Pressing backspace here is not intended to close the autocompletion.

Example:
Having page.10.tabl with open autocompletion and pressing backspace multiple times, it refreshes the suggestion list when the cursor reaches the . separator. Closing the autocompletion will destroy this feature. If you want to close the autocompletion you can still press Escape.

I guess there is a solution for this use-case, but that's imho not a bug and not scope of the stab phase.

#3

Updated by Wouter Wolters almost 6 years ago

  • Target version deleted (7.4 (Backend))
  • Sprint Focus deleted (Stabilization Sprint)

I agree with Andreas here. Removed from the 7.4 board.

#4

Updated by Andreas Fernandez about 4 years ago

  • Status changed from On Hold to Rejected

Also available in: Atom PDF