Bug #68909

FAL "Select & uplodad files" button not working for inline records

Added by Philipp Roski about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2015-08-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It seems that the "Select & upload files" function is not working for inline records => the TYPO3 element browser is not shown after clicking the link/button. If I create the record directly (not as an inline record) the file upload works perfectly. Here's the field configuration I'm using:

'image' => array(
    'config' => \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::getFileFieldTCAConfig('image', array(
        'maxitems' => 1,
        'foreign_types' => array(
            \TYPO3\CMS\Core\Resource\File::FILETYPE_IMAGE => array(
                'showitem' => '
                    --palette--;;filePalette
                ',
            ),
        ),
    ), $GLOBALS['TYPO3_CONF_VARS']['GFX']['imagefile_ext']),
),

Best regards
emphis

#1

Updated by Riccardo De Contardi almost 6 years ago

  • Category set to File Abstraction Layer (FAL)
  • Status changed from New to Needs Feedback

Philipp, can you tell us if the latest master still has this problem?

#2

Updated by Jacob Dreesen over 5 years ago

I had the same problem with 7.5-dev.
I just updated to 7.6.2 and it works for me now :)

#3

Updated by Riccardo De Contardi over 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Thank you

Also available in: Atom PDF