Bug #69317

Epic #65814: Make Indexed search extbase plugin shine

Indexed Search: errors in experimental mode when searching for empty string

Added by Manuel Link over 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2015-08-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When searching for an empty string in experimental mode several warnings like
"Core: Error handler (FE): PHP Warning: Invalid argument supplied for foreach()"
appear in the log.
Sometimes (I think the first time searching for an empty string after flushing the caches) it even results in a php-error like
"Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1237900529: The argument "each" was registered with type "array", but is of type "boolean" in view helper "TYPO3\CMS\Fluid\ViewHelpers\ForViewHelper""

The reason for this is the return value of the function "getSearchWords" in the file SearchController.php,
which is "FALSE" instead of an array.

I can think of two possible solutions of this problem:

initializing "$sWordArray" as an empty array instead of "FALSE",
or checking whether it is an Array at the end of the function and setting it as an array if it isnt.

#1

Updated by Tymoteusz Motylewski about 5 years ago

  • Parent task set to #65814
#2

Updated by Tymoteusz Motylewski almost 5 years ago

confirmed in 6.2.15. Bug is fixed already in 7.

#3

Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45222

#4

Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45222

#5

Updated by Gerrit Code Review almost 5 years ago

Patch set 3 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45222

#6

Updated by Tymoteusz Motylewski almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF