Bug #69399

Fatal Error due to class object inconsistencies in Form Wizard

Added by Oliver Hader almost 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2015-08-28
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Elements in the form wizard can either be defined by TypoScript or by using the accordant wizard. Some of these elements don't have a counterparts in the ExtJS form wizard and thus only work in the TypoScript mode. In these cases, the missing JSON conversion objects lead to fatal errors.

Example TypoScript for triggering the error:
8 = IMAGEBUTTON
8 {
label = Image button
src = /typo3conf/ext/bootstrap_package/Resources/Public/Images/Backend/TopBarLogo-v7@2x.png
value = value
}

Associated revisions

Revision 791cb96f (diff)
Added by Oliver Hader almost 5 years ago

[BUGFIX] Fatal Error due to class object inconsistencies in ext:form

Elements in the form wizard can either be defined by TypoScript or
by using the accordant wizard. Some of these elements don't have a
counterparts in the ExtJS form wizard and thus only work in the
TypoScript mode. In these cases, the missing JSON conversion
objects lead to fatal errors.

Resolves: #69399
Releases: master, 6.2
Change-Id: Ide39afcbdc483dc01d9cdc9165c89c34785f847d
Reviewed-on: http://review.typo3.org/42913
Reviewed-by: Wouter Wolters <>
Reviewed-by: Sebastian Wagner <>
Tested-by: Bjoern Jacob <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

Revision efe27138 (diff)
Added by Oliver Hader almost 5 years ago

[BUGFIX] Fatal Error due to class object inconsistencies in ext:form

Elements in the form wizard can either be defined by TypoScript or
by using the accordant wizard. Some of these elements don't have a
counterparts in the ExtJS form wizard and thus only work in the
TypoScript mode. In these cases, the missing JSON conversion
objects lead to fatal errors.

Resolves: #69399
Releases: master, 6.2
Change-Id: Ide39afcbdc483dc01d9cdc9165c89c34785f847d
Reviewed-on: http://review.typo3.org/42924
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42913

#2 Updated by Bjoern Jacob almost 5 years ago

Here's a complete snippet:


enctype = multipart/form-data
method = post
prefix = tx_form
confirmation = 1
postProcessor {
    1 = mail
    1 {
        recipientEmail = 
        senderEmail = 
    }
}
10 = IMAGEBUTTON
10 {
    label = Image button 
    src = EXT:t3skin/images/spinner/d5d5d5.gif
    value = value
}

#3 Updated by Gerrit Code Review almost 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42924

#4 Updated by Oliver Hader almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF