Bug #70116

Missing style prefix in admin_panel.css breaks website frontend styling

Added by Christoph Dörfel about 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2015-09-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

We just happen to include the same FontAwesome icon styles that the AdmPanel is using.
Most style definitions in the admin_panel.css are prefixed with #TSFE_ADMIN_PANEL_FORM, except for one: ".fa:before".

On a second note... maybe renaming the AdmPanel font-family from 'FontAwesome' to something like 'Typo3FontAwesome' would be useful too. What would the implications of that be?

#1

Updated by Christoph Dörfel about 6 years ago

Ugh. Sorry... This seems to be fixed in the master branch.

Anyway: The (possible) issue with the introduction of a new font family that overrides existing definitions persists.

#2

Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43569

#3

Updated by Daniel Goerz about 6 years ago

  • Sprint Focus set to Stabilization Sprint
#4

Updated by Christoph Dörfel about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF