Bug #70208

Epic #69955: Optimize new Extbase/ Fluid based rewrite of EXT:form

EXT:form - Problems with radiogroup in email

Added by Bjoern Jacob about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2015-09-30
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If I use a radiogroup I get in the email the labels plus the value, if the value is empty I get the automatic generated one.
That's just in the email.

For example without value: Anrede Herr3

If I write the "Herr" as value in TS: Anrede HerrHerr


Related issues

Related to TYPO3 Core - Bug #70095: EXT:form - Wrong Checkbox and Radiobutton handling Closed 2015-09-24

History

#1 Updated by Bjoern Jacob about 4 years ago

  • Priority changed from Should have to Must have
  • Sprint Focus set to On Location Sprint

#2 Updated by Bjoern Jacob about 4 years ago

  • Status changed from New to Closed
  • Assignee deleted (Ralf Zimmermann)

I cannot reproduce the problem. For testing I've used this setup:


enctype = multipart/form-data
method = post
prefix = tx_form
confirmation = 1

postProcessor {
    1 = mail
    1 {
        recipientEmail = your@email.com
        senderEmail = your@email.com
    }
}

10 = RADIOGROUP
10 {
    class = fieldset-subgroup
    legend {
        value = Radio group 1 (with values)
    }
    name = radiogroup1

    10 = RADIO
    10 {
        label {
            value = Option 1
        }
    }

    20 = RADIO
    20 {
        label {
            value = Option 2
        }
    }

    30 = RADIO
    30 {
        label {
            value = Option 3
        }
    }
}

20 = RADIOGROUP
20 {
    class = fieldset-subgroup
    legend {
        value = Radio group 1 (without values)
    }
    name = radiogroup2

    10 = RADIO
    10 {
        label {
            value = Option 1
        }
        value = option4
    }

    20 = RADIO
    20 {
        label {
            value = Option 2
        }
        value = option5
    }

    30 = RADIO
    30 {
        label {
            value = Option 3
        }
        value = option6
    }
}

100 = SUBMIT
100 {
    name = submit
    value = Submit
}

If you think there is still something not working please re-open the issue. We're happy to help you.

#3 Updated by Anja Leichsenring almost 4 years ago

  • Sprint Focus deleted (On Location Sprint)

Also available in: Atom PDF