Project

General

Profile

Actions

Bug #70263

closed

LocalConfiguration.php not seen was writable if typo3conf directory is not writable

Added by André Haehnel almost 9 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-10-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

ConfigurationManager::canWriteConfiguration only returns true if the typo3conf directory is writable.

We have installations in which the LocalConfiguration.php file itself is writable, but the typo3conf path is not writable. TYPO3 refuses to update the config there, although it could actually write.

The issue exists in 6.2 and 7.5 as well.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #82289: Check for LocalConfiguration.php and not if typo3conf is writableClosedBenni Mack2017-09-04

Actions
Actions #1

Updated by Jigal van Hemert over 8 years ago

  • Status changed from New to Needs Feedback

What does the Folder Structure section in the Install Tool report? And the Reports module section "TYPO3 System", line "File System"? typo3conf must be writable, so this is IMO a configuration error, not a bug.

Actions #2

Updated by Riccardo De Contardi about 8 years ago

  • Status changed from Needs Feedback to Accepted

a brief list of what should be done:
- the log still says "localconfiguration not writeable" even if it is writable, but /typo3conf/ is not, and this should be corrected
- the installation document https://github.com/TYPO3/TYPO3.CMS/blob/master/INSTALL.md and https://docs.typo3.org/typo3cms/InstallationGuide/QuickInstall/GetAndUnpack/Index.html should report that /typo3conf/ must be writable

Actions #3

Updated by Riccardo De Contardi almost 7 years ago

  • Related to Bug #82289: Check for LocalConfiguration.php and not if typo3conf is writable added
Actions #4

Updated by Riccardo De Contardi almost 7 years ago

  • Status changed from Accepted to Closed

I close this as it is already fixed in master, v8.7.x and v7.6.x .

Please reopen it or open a new issue with a reference to this one if you think that this is the wrong decision, experience the issue again.

Thank you.

Actions

Also available in: Atom PDF