Bug #70373

RTE not working with Edge browser (Windows 10)

Added by Marcel Burkhalter over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2015-10-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It's not possible to write in the RTE field using the Edge browser on Windows 10. As soon as you type a character, the RTE field seems to loose focus (blinking cursor disappears). Writing and pasting using ctrl+v works when switched to HTML mode but in regular WYSIWYG mode you can't type or paste.
Tested with browserstack.com.


Related issues

Related to TYPO3 Core - Bug #74384: Cannot edit text in Microsoft EdgeClosed2016-03-07

Actions
#1

Updated by Ralf Ellersiek over 5 years ago

I will confirm this behavior: Under Typo3 6.2 and 7.4 the rte won't work with the edge browser (same behavior as marcel has described).
I don't know, if this issue is caused by the rte or by the edge browser (I use the edge browser very often, and currently I have only three issues with the edge).

#2

Updated by Mikael Conley over 5 years ago

Come on guys!
We all have clients that use Edge.
I know we all hate it but we need to support it if we want to be an Enterprise CMS.

#3

Updated by Angelo Previtali about 5 years ago

I can confirm the problem with the actual EDGE browser Version 25.10586.00: The RTE Editor can not be used for editing text in a TYPO3 version 6.2.17 with Windows 10. This should be not a "should have" but a "Must have".

#4

Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47037

#5

Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47071

#6

Updated by Anonymous about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Gerrit Code Review about 5 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47073

#8

Updated by Gerrit Code Review about 5 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47073

#9

Updated by Gerrit Code Review about 5 years ago

Patch set 3 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47073

#10

Updated by Gerrit Code Review about 5 years ago

Patch set 4 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47073

#11

Updated by Gerrit Code Review about 5 years ago

Patch set 5 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47073

#12

Updated by Gerrit Code Review about 5 years ago

Patch set 6 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47073

#13

Updated by Anonymous about 5 years ago

  • Status changed from Under Review to Resolved
#14

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF