Bug #70463

Suggestions can't be selected by cursor keys

Added by Stefan Froemken over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2015-10-07
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

when using the suggest wizard I have to choose my selection by mouse. It is not possible to choose a selection by cursor keys of my keyboard.
I'm pretty sure that this works in earlier versions.

Stefan


Related issues

Related to TYPO3 Core - Bug #70382: Highlight current result item in suggest wizard Closed 2015-10-05
Related to TYPO3 Core - Bug #76286: Items added to group fields via suggest wizard contain HTML Closed 2016-05-24

Associated revisions

Revision 36b4043c (diff)
Added by Daniel Siepmann over 3 years ago

[BUGFIX] TCA Suggest Wizard usable with keyboard

As styling was already there, but just for mouse, and same is true for
selecting results. The keyboard events now trigger the same behaviour.

Change-Id: Ie265f3b5785efc89f7148b8303d9b62c3a5add88
Resolves: #70463
Releases: master, 7.6
Reviewed-on: https://review.typo3.org/47932
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>

Revision 7739b744 (diff)
Added by Daniel Siepmann over 3 years ago

[BUGFIX] TCA Suggest Wizard usable with keyboard

As styling was already there, but just for mouse, and same is true for
selecting results. The keyboard events now trigger the same behaviour.

Change-Id: Ie265f3b5785efc89f7148b8303d9b62c3a5add88
Resolves: #70463
Releases: master, 7.6
Reviewed-on: https://review.typo3.org/47926
Reviewed-by: Daniel Siepmann <>
Tested-by: Daniel Siepmann <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>

History

#1 Updated by Daniel Siepmann over 3 years ago

That works in 6.2 LTS without any problems and since 7 you lose a lot of time by using the mouse instead.

#2 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47926

#3 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47926

#4 Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47932

#5 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47932

#6 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47932

#7 Updated by Gerrit Code Review over 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47932

#8 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47926

#9 Updated by Daniel Siepmann over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF