Feature #70979

Usability: Better handling of multiple versions in Extension Mangager

Added by Sybille Peters almost 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2015-10-23
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

IMHO, if the TYPO3 version dependencies in an Extension are set correctly, the EM should correctly display only availabe extension versions for this current TYPO3 version.

Reproduce

  1. TYPO3 6.2.15
  2. install typo3_console
  3. Version 1.2.3 of typo3_console is displayed by default when trying to fetch via Extension Manager, which is the current version but only runs on 7.x. IMHO the last available version for 6.2 should be displayed by default

Additionally: The list of available extension versions will not show for which TYPO3 version they are available.

Due to this, it is tedious to select the correct version.

History

#1 Updated by Riccardo De Contardi almost 4 years ago

  • Category set to Extension Manager

#2 Updated by Nicole Cordes over 2 years ago

  • Status changed from New to Needs Feedback

IMHO this was solved for EM in TYPO3 7.6

#3 Updated by Riccardo De Contardi over 2 years ago

I tried the following test with 7.6.16:

I updated the extension list in BE and tried to install the extension "bsdist". As far as I have seen the current version 2.0.1 supports only TYPO3 8.7.0 - 8.7.99; while 1.3.3 supports 6.2.0 - 7.6.99.

Result: the version 2.0.1 has been downloaded.

#4 Updated by Sybille Peters over 2 years ago

Thank you for the feedback. I think it is fixed with 7.6 as well.

#5 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Needs Feedback to Closed

I close this one for now as seems resolved.

If you think that this is the wrong decision or experience the issue again, then please reopen it or open a new ticket and add a relation to this ticket number.

Thank you very much and sorry for the late answer.

#6 Updated by Sybille Peters almost 2 years ago

  • Description updated (diff)

Also available in: Atom PDF