Bug #71253

Folder Creation Fails If Same Folder Exists at File Storage Root

Added by Jeff Segars almost 4 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-11-02
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Creating a new folder in Filelist fails if a folder of the same name exists in the file storage root. This is due to the $this->driver->folderExists() check in \TYPO3\CMS\Core\Resource\ResourceStorage->createFolder() that only considers the new folder name and not the parent folder. I'd assume this should actually be a call to $this->driver->folderExistsInFolder() instead.

Steps to Reproduce:
1) Create "folder1" in the file storage root.
2) Create "folder2" in the file storage root.
3) Attempt to create "folder1" inside "folder2"

ResourceStorage.php.diff View (923 Bytes) Jeff Segars, 2015-11-02 18:17

Associated revisions

Revision 90519608 (diff)
Added by Mathias Schreiber almost 4 years ago

[BUGFIX] Allow creation of nested folders with same name

Due to a faulty check it was disallowed to create a folder
with the same name as the parent folder.

Resolves: #71253
Releases: master
Change-Id: Iecf1f17534958f10363538dc74612e9a52435a0d
Reviewed-on: https://review.typo3.org/44485
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44485

#2 Updated by Mathias Schreiber almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF