Bug #71437

Side effects on processing access permissions in a workspace

Added by Oliver Hader about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2015-11-09
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Associated revisions

Revision f870b333 (diff)
Added by Oliver Hader about 4 years ago

Revert "[BUGFIX] Do not overlay version on empty row"

This reverts commit 4012b988b9f6905429eabd1f1a44adc57b1c95f6.
The commit dbb29f3d61051ffbcf7d0ec8770d755b1d33a512, that made
this one necessary will be reverted as well.

Reverts: #69642
Resolves: #71437
Releases: master
Change-Id: Id8c3aa249e449bc49bdadb832dee12ff89d871ae
Reviewed-on: https://review.typo3.org/44630
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision 706d5bb8 (diff)
Added by Oliver Hader about 4 years ago

Revert "[BUGFIX] Draft usergroup access rights are now respected"

This reverts commit dbb29f3d61051ffbcf7d0ec8770d755b1d33a512.

The mentioned change has been reverted in the 6.2 earlier but
was still remaining in the master branch. Albeit the initial
change seems to be helpful, there are lots of side effects
that have not been considered and cannot be enhanced easily.

Reverts: #33436
Resolves: #71437
Releases: master
Change-Id: I7821e0695a963eb52ed75621e17462ffca3ec2c3
Reviewed-on: https://review.typo3.org/44639
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision 992840ba (diff)
Added by Helmut Hummel about 4 years ago

[FOLLOWUP] Revert "[BUGFIX] Draft usergroup access rights are now respected"

Fix Unit tests.

Resolves: #71437
Releases: master
Change-Id: I57084daa13fcea9684e5e74d9454ef2e3c2f7b1f
Reviewed-on: https://review.typo3.org/44648
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Gerrit Code Review about 4 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44630

#2 Updated by Gerrit Code Review about 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44639

#3 Updated by Oliver Hader about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Stephan GroƟberndt about 4 years ago

  • Subject changed from SIde effects on processing access permissions in a workspace to Side effects on processing access permissions in a workspace

#5 Updated by Gerrit Code Review about 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44648

#6 Updated by Helmut Hummel about 4 years ago

  • Status changed from Under Review to Resolved

#7 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF