Bug #71616

Cloned domain entity has __identity set in Fluid form

Added by Oliver Hader over 5 years ago. Updated 10 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2015-11-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If an Extbase domain entity is cloned, it internally will be flagged. If that entity is passed to some form view helper in a Fluid based view, the __identity notation is rendered as hidden field. As a result, the original(!) entity that has been cloned will be used after the form is submitted back to the server.

#1

Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44744

#2

Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44744

#3

Updated by Markus Sommer over 5 years ago

  • Assignee set to Oliver Hader
#4

Updated by Gerrit Code Review about 5 years ago

Patch set 3 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44744

#5

Updated by Christian Kuhn over 4 years ago

  • Status changed from Under Review to New
#6

Updated by Christian Kuhn over 4 years ago

issue probably still valid, 6.2 patch was however abandoned as "too late", could be re-done for master.

#7

Updated by Oliver Hader 10 months ago

  • Assignee deleted (Oliver Hader)

Also available in: Atom PDF