Bug #71771

RTE.default.contentCSS is broken in Frontend

Added by Chris topher over 3 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Won't have this time
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2015-11-22
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The page TSconfig property RTE.default.contentCSS allows to define one or more CSS files, which are then used by the RTE to style the text inside the RTE. An example is

RTE.default.contentCSS = fileadmin/template/style_rte.css

In the backend this is working correctly.

However, if the RTE is opened from the frontend, then this does not work. The RTE then tries to get the CSS file from a wrong URL.
It seems like the path calculation in rtehtmlarea/Classes/Form/Element/RichTextElement.php, function getContentCssFileNames() does not work correctly.


Related issues

Related to TYPO3 Core - Bug #73163: RTE in FE does not show available blockstyles at first try Needs Feedback 2016-02-06
Related to TYPO3 Core - Story #73183: Removal of frontend simulation in all ViewHelpers Under Review 2016-02-08

History

#1 Updated by Chris topher over 3 years ago

  • Description updated (diff)

#2 Updated by Chris topher over 3 years ago

  • Is Regression changed from No to Yes

#3 Updated by Chris topher over 3 years ago

  • Description updated (diff)

#4 Updated by Andreas Allacher over 3 years ago

In that regard there are some small differences regarding frontend / frontend editing check in RteHtmlAreaApi and RichTextElement.
There are some methods that basically also do the same, maybe the should be moved in a utility?
e.g. there is a isFrontendEditing check method in both that does the same.
Then there is writeTemporaryFile and getFullFilename.
And there is also differences in those two. getfullFilename checks in RteHtmlAreaApi regarding isFrontend() || isFrontendEditing().
In RichTextElement it only checks for isFrontendEditing.

Also the check in writeTemporaryFile has been improved in RtehtmlAreaApi.

Maybe this issue is realted, would have to test it.

#5 Updated by Riccardo De Contardi over 3 years ago

are these two related? #65705 #65608

#6 Updated by Chris topher over 3 years ago

In #65705 the problem obviously only exists on FE pages, which contain something that looks like a domain name in the page title. This is not the case for me: My pages do not look like a domain name. Also I have the issue on all pages.

I do use RealURL and I can confirm that config.absRefPrefix is set. So the situation at least is similar to the one in #65608.

#7 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48580

#8 Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48580

#9 Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48580

#10 Updated by Gerrit Code Review almost 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48580

#11 Updated by Gerrit Code Review over 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48580

#12 Updated by Anja Leichsenring about 1 year ago

  • Status changed from Under Review to Needs Feedback

with ckeditor in place now, is the issue still relevant?

#13 Updated by Chris topher 12 months ago

  • Status changed from Needs Feedback to Closed
  • Priority changed from Should have to Won't have this time

As RTE.default.contentCSS is only used in the old RTE and not in CKEditor, this is not relevant for CKEditor.

Also available in: Atom PDF