Bug #71787

Redirection to Install Tool

Added by Bernhard Eckl over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2015-11-23
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The new TYPO3 7 has a .htaccess redirect to the path of the install tool when typing domain.xy/typo3/install. But when using nginx there is no redirection. Better would be a redirect via PHP, so it doesn’t rely on Apache .htaccess.


Related issues

Related to TYPO3 Core - Task #54316: Provide a Nginx server configuration Closed 2013-12-11

History

#1 Updated by Wouter Wolters over 4 years ago

  • Status changed from New to Needs Feedback
  • Assignee deleted (Mathias Schreiber)

This is done with a reason.
https://docs.typo3.org/typo3cms/extensions/core/latest/Changelog/7.5/Breaking-68812-DeprecatedBackendEntrypointsMoved.html

How would you solve this PHP wise without reintroducing the typo3/install folder?

#2 Updated by Bernhard Eckl over 4 years ago

It’s not possible. But a shorter link would be good… like typo3/?parameter=install. Or at least an nginx config for that redirection.

#3 Updated by Christian Kuhn over 4 years ago

  • Status changed from Needs Feedback to Closed

yeah. no additional entry point anymore. but, something could be mentioned to a dummy nginx configuration. so, this issue will be closed as duplicate of #54316.

Also available in: Atom PDF