Project

General

Profile

Actions

Bug #71980

closed

RTE queryParametersSelector must be set

Added by Eric Chavaillaz about 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2015-11-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

In the RTE, in the class "BrowseLinksController" on the line 411 there is a check to see if the variable "$this->buttonConfig['queryParametersSelector.']['enabled']" is set or not. The problem is that in the documentation, this variable is set to 0 by default. So this check is unnecessary because if somebody want to hide this input he must add the property in his page TS config : RTE.default.buttons.queryParametersSelector.enabled = 0.

I purpose to change the lines 411 to 414 like this :

if (!$this->buttonConfig['queryParametersSelector.']['enabled']) {
    unset($fieldRenderingDefinitions['params']);
}

Thanks

Actions #1

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45057

Actions #2

Updated by Markus Klein about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #3

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF