Bug #72428

Localization problem in Turkish language

Added by Selim no-lastname-given about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-12-23
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Everything was ok in 6.xx versions of Typo3. After upgrading Typo3 7.xx, extensions don't work in Turkish language.

Our default language is Turkish, and second language is English:

config.linkVars = L
config.sys_language_uid = 0
config.language = tr
config.locale_all = tr_TR
config.htmlTag_langKey = tr
config.sys_language_mode=content_fallback ; 1
[globalVar=GP:L=1]
config.sys_language_uid = 1
config.language = en
config.locale_all = en_EN
config.htmlTag_langKey = en
[global]

In this case, we can translate everything. Content elements are ok as well. But when we add an extension just like Powermail or Language Selection, the extension works only in English version of the pages. I thought the problem was caused by general Default Language issues and have been trying to solve the problem for 3-4 days. But when i changed the default language to German, French or English in TypoScript, the extensions work in default language, too. So i see the problem is related to Turkish language. I hope you can find a solution for that soon.

History

#1 Updated by Markus Klein about 4 years ago

Did you check that the locale "tr_TR" is really available on the server?

#2 Updated by Markus Klein about 4 years ago

  • Status changed from New to Needs Feedback

#3 Updated by Selim no-lastname-given about 4 years ago

Hi Markus,
Thank you for your quick response. I don't know how but i changed to;

config.linkVars = L
config.sys_language_uid = 0
config.language = de
config.locale_all = de_DE
config.htmlTag_langKey = de

And then, again, i changed to;

config.linkVars = L
config.sys_language_uid = 0
config.language = tr
config.locale_all = tr_TR
config.htmlTag_langKey = tr

And now everything is ok. I reinstalled Typo3 7.xx many times, and finally it works in this way.
Thank you.

#4 Updated by Wouter Wolters about 4 years ago

  • Status changed from Needs Feedback to Closed

Great it worked for you:)

Also available in: Atom PDF