Project

General

Profile

Actions

Bug #72436

closed

Scheduler fails to run (cron)

Added by Kurt Ludikovsky about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
scheduler
Target version:
Start date:
2015-12-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

A similar error has been reported here [[https://forge.typo3.org/issues/64931]].

The cron job return the following error, which can be reproduced by manually starting the Scheduler task

root@vps:~# /var/www/vhosts/dom.tld/httpdocs/typo3/cli_dispatch.phpsh scheduler
PHP Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) in /var/www/vhosts/dom.tld/httpdocs/typo3_src-7.6.1/typo3/sysext/backend/Classes/Console/Application.php on line 40
root@vps:~#

As from the attached screen shots can be ssen, the settings of scheduler should be ok, as shall be the PHP version.

The only thing I recognised is the 'weird' setting of the cli_constants. There seems to be a recursion /self reference. Interestingly in this regards is that 1-entry moves also with each opening of the 0-entry to the right too.


Files

_Screen_Shot_2015-12-25_095713b.jpg (61.8 KB) _Screen_Shot_2015-12-25_095713b.jpg Scheduler setup check Kurt Ludikovsky, 2015-12-25 10:26
_Screen_Shot_2015-12-25_100005b.jpg (21.6 KB) _Screen_Shot_2015-12-25_100005b.jpg PHP Version / T3 System Info Kurt Ludikovsky, 2015-12-25 10:26
_Screen_Shot_2015-12-25_095600b.jpg (56.2 KB) _Screen_Shot_2015-12-25_095600b.jpg Globals Settings for clikeys Kurt Ludikovsky, 2015-12-25 10:26
Actions #1

Updated by Wouter Wolters about 8 years ago

  • Status changed from New to Closed

Your cli php version is too low to run TYPO3 CMS version 7.

Actions #2

Updated by Kurt Ludikovsky about 8 years ago

What is the required PHP Version.
According [[https://typo3.org/news/article/php-minimum-requirements-for-typo3-cms-7/]] it is 5.5.
I have 5.6.15 as can be seen from the screenshots.

So what shall I do?

Actions #3

Updated by Kurt Ludikovsky about 8 years ago

Solved it.
Solution for those who have a similar issue.

Issue:
I am running two version of PHP on my VPS system under PLESK to cover several versions of Typo3.

So the base version is 5.4.x while for some vhosts the version can be set to be 5.6.x.
But the cron is running from the base version (5.4.x). This can be verified by php -v on the command line.

Solution:

I have modified the cron task to pass it to the proper PHP-interpreter.

/opt/plesk/php/5.6/bin/php /var/www/vhosts/dom.tld/httpdocs/typo3/cli_dispatch.phpsh scheduler
Actions

Also available in: Atom PDF