Bug #72502

FE menu page disappears if Shortcut Mode is First Subpage and Shortcut Target has a value

Added by Charles Coleman almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-01-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

In TYPO3 7.6.2, each page that is set like this disappears from the FE menu:

  1. Page Type is set to Shortcut
  2. Page Shortcut Mode is set to First subpage of selected/current page
  3. Page Shortcut Target has something set in it

I didn't notice this behavior in TYPO3 7.1 so think this is regression. Gianluigi Martino also confirmed this error in 7.6.

​*Work Around:*​ I don't have a solution but a work around can be to remove the value in the Shortcut Target field. ​_(Doesn't it seem that the Shortcut Target field should be hidden when First subpage of selected/current page is chosen? It should be an irrelevant field at that point.)_​

#1

Updated by Charles Coleman almost 6 years ago

  • Target version changed from 7.6.3 to 8.0

This might likely would be an issue in 8.0 as well since it's a regression I think.

#2

Updated by Georg Ringer almost 6 years ago

  • Status changed from New to Needs Feedback

question about "Page Shortcut Target has something set in it" > so does this "something"-page got subpages? because of course this is required by switching it so a mode which states "First subpage of selected/current page".

#3

Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (8.0)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF