Bug #72515

Double "title" in links of images

Added by Dirk Klimpel almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2016-01-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I create a content element with an image with a link and I set a title to the image and a title to the link, in HTML source appear both titles.

<a href="file.html" title="information2" title="information1">

That is not valid HTML.

The image should get the title of the image. And the link should get the title of the link.
When the link has no title, it can get the title of the image.


Files

be_settings.JPG (22.4 KB) be_settings.JPG Dirk Klimpel, 2016-01-04 00:38
#1

Updated by Markus Klein almost 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (next-patchlevel)

Are you using css_styled_content of fluid_styled_content?
Are you using latest 7.6.2?

#2

Updated by Dirk Klimpel almost 6 years ago

TYPO3 release 7.6.2
css_styled_content
I am tested it as well css_styled_content as css_styled_content v6.2.
Both the the same result.

#3

Updated by Dirk Klimpel almost 6 years ago

fluid_styled_content is not installed.

#4

Updated by Markus Klein almost 6 years ago

Ok, I've to test with CSC then, because I can't reproduce the issue with FSC.

#5

Updated by Riccardo De Contardi almost 6 years ago

I think this is the consequence of having set the TS constants:

styles.content.imgtext.titleInLink = 1
styles.content.imgtext.titleInLinkAndImg  = 0

(which is the default); if you set styles.content.imgtext.titleInLinkAndImg = 1 everything goes right.
By the way: I guess there is very little point in having both the title for link and image set at the same time

#6

Updated by Dirk Klimpel almost 6 years ago

Setting styles.content.imgtext.titleInLinkAndImg = 1 does not change anything in <a> tag.
If I set styles.content.imgtext.titleInLink = 0 in <a> tag is the title of link and in <img> tag is the title of the image and there is no double title in <a> tag.

I have the same TS in TYPO3 6.2. There I do not have double title in <a> tag. There is the title in <a> tag always the title of the image. TYPO3 7.6 and 6.2 create different outputs.

You are right. I will remove the title of the link in this case. Then is the problem.

#7

Updated by Markus Klein almost 6 years ago

I just tested this on 6.2.17 and I also get the double title there.

#8

Updated by Dirk Klimpel almost 6 years ago

Whyever. I have no problems in 6.2.17. I had a look in the source of css_styled_content/Classes/Controller/CssStyledContentController.php. The part for the title tag is the same in 6.2.17 and 7.6.
It doesn't matter. I will change my links and titles.

Than can you close this case.

#9

Updated by Markus Klein almost 6 years ago

  • Status changed from Needs Feedback to Closed

Alright. Feel free to reopen, whenever you see the need. Contact us on Slack.

Also available in: Atom PDF