Project

General

Profile

Actions

Bug #72786

closed

FAL "Save document and create a new one" leads to error message

Added by Tabea David over 8 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2016-01-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Uncaught TYPO3 Exception
#1392926871: I could not find a valid file identifier

This button shouldn't be visible in the filelist view (edit mode) because it doesn't make any sense at that point (we can't create new files here this way).


Files

save-and-create.png (19 KB) save-and-create.png Tabea David, 2016-01-18 13:52

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #70783: Save and new in sys_file_metadataClosed2015-10-16

Actions
Actions #1

Updated by Wouter Wolters over 8 years ago

  • Status changed from New to Needs Feedback

Can you add a screenshot were you see this button?

Actions #2

Updated by Tabea David over 8 years ago

File > Filelist > Edit a file (TYPO3 6.2.17)

Actions #3

Updated by Riccardo De Contardi over 8 years ago

  • Status changed from Needs Feedback to New

Ok, the issue is present on TYPO3 6.2.17 but not on 7.6.x

Steps to reproduce:
filelist > edit the metatadata for the file > the button for "save and create new" is present, but it would create only another metadata record on database... without a file!

On version 7.6 the only available options for save are save & save and close.

Actions #4

Updated by Wouter Wolters over 8 years ago

Solution that has been merged during 7 development was to add the following UserTSConfig:

options.saveDocNew.sys_file = 0
options.saveDocNew.sys_file_metadata = 0
options.disableDelete.sys_file = 1

Actions #5

Updated by Tabea David over 8 years ago

Thanks a lot! This solved the problem immediately.
I won't close/resolve this issue because I still think this should be disabled by default.

Actions #6

Updated by Gianluigi Martino over 8 years ago

  • Assignee set to Gianluigi Martino
Actions #7

Updated by Gianluigi Martino over 8 years ago

  • Status changed from New to In Progress
Actions #8

Updated by Gerrit Code Review over 8 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46120

Actions #9

Updated by Gianluigi Martino over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Benni Mack almost 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF