Bug #72965

f:uri.image doesn't really crop the image

Added by Christian Toffolo over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Fluid
Target version:
Start date:
2016-01-27
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

{f:uri.image(image: file, width: 100c, height: 100c)}
should create a 100x100px crop of the central portion of the image.
Instead it wrongly creates a 100x100px version of the whole image distorted to look square.
See attached image.

FluidCrop.jpg View (48.3 KB) Christian Toffolo, 2016-01-27 13:48

History

#1 Updated by Christian Toffolo over 3 years ago

Sorry, not a bug but my mistake cause I forgot that in this case the values must be wrapped with quotation marks like this: {f:uri.image(image: file, width: '100c', height: '100c')}

If the values are not wrapped with quotation marks they are converted to integer "100".
Btw, an error message could be useful.

#2 Updated by Georg Ringer over 3 years ago

  • Status changed from New to Resolved

#3 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF