Project

General

Profile

Actions

Bug #73239

closed

Clear processed files leads to 404 errors

Added by Fabrice Morin over 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2016-02-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In the news extension RTE, we can reference an image which will be optionally resized and written in the processed folder. I suppose it's also the case for a standard text content in TYPO3.

In the install tool, there is an option to clear processed files. This task will remove all processed files, but those file will still be present in the RTE (their names match the original file suffixed with a MD5).
This leads to missing images in frontend, as TYPO3 doesn't automatically handle the generation of the missing processed images.

Is there a way to generate the deleted images by the install tool still referenced in the RTEs ?


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #56147: Regenerate missing RTE magic image on renderingClosed2014-02-20

Actions
Actions #1

Updated by Pavel Filippov almost 8 years ago

  • TYPO3 Version changed from 6.2 to 7

The same problem with version 7.6.10. Cleanup files leads to their complete removal. This applies to files which have been inserted on the page with the "copy-paste", for example, from another site.
Thus, the problem relates to files that are processed on the fly and have no sources that are stored in users folders (uploads etc.). This is a problem that turns an excellent future into a big problem.

Actions #2

Updated by Riccardo De Contardi over 7 years ago

  • Category set to File Abstraction Layer (FAL)
Actions #3

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from New to Closed

We are sorry, but we close this issue as now TYPO3 uses CKEditor and RTEHtmlarea is no more supported by TYPO3 .

RTEHtmlarea development has stopped - it has been decoupled from the core and its code is available on GitHub:
https://github.com/FriendsOfTYPO3/rtehtmlarea

If you still need this fixed please create a PR on GitHub

If you think that this is the wrong decision or experience the issue again on more recent TYPO3 version (8.7.x) please reopen it or
open a new issue with a reference to this one. Thank you.

Regards
Riccardo De Contardi

Actions

Also available in: Atom PDF