Bug #73475

Save and view page does not work with shortcut or external URL

Added by Peter Kraume over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-02-16
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When you edit the page properties of a page with type shortcut or external url and than hit the "Save and view page" button, you're not redirected to the expected page or external URL but to the startpage.
Using the "Show" button in the context menu leads to a correct redirect.


Related issues

Related to TYPO3 Core - Bug #73428: Save and View a newly created page redirects to site root Closed 2016-02-15

Associated revisions

Revision 96a1c1c9 (diff)
Added by Wouter Wolters over 4 years ago

[BUGFIX] Fix save and view page for a new page record

The current page id is not set correctly because the popViewId
contains not the uid of the created page. Because it is meant
to fetch the uid of the current page anyway we can
use the record id.

Resolves: #73428
Resolves: #73475
Releases: master,7.6
Change-Id: I4c34547d9a9cf8acd1de01473e931d0fb6a634d8
Reviewed-on: https://review.typo3.org/46736
Reviewed-by: Peter Kraume <>
Tested-by: Peter Kraume <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision ac62c7f7 (diff)
Added by Wouter Wolters over 4 years ago

[BUGFIX] Fix save and view page for a new page record

The current page id is not set correctly because the popViewId
contains not the uid of the created page. Because it is meant
to fetch the uid of the current page anyway we can
use the record id.

Resolves: #73428
Resolves: #73475
Releases: master,7.6
Change-Id: I4c34547d9a9cf8acd1de01473e931d0fb6a634d8
Reviewed-on: https://review.typo3.org/46744
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46736

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46736

#3 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46744

#4 Updated by Wouter Wolters over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF