Bug #73598

Three hash (###) marker in JavaScript creates the problem in TYPO3 6.2.18

Added by Jignesh Prajapati over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2016-02-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

I had one extension which is pi based.

It was working fine with TYPO3 6.2.15 but after upgrading to TYPO3 6.2.18, it creates the problem in rendering of the extension template using the function substituteMarkerArrayCached.

After debugging the extension HTML template, i find out that below line of JavaScript was creating the problem.

$("#obj_price").formatNumber({format:"#,###.00", locale:"de"});

If you see the above JavaScript line, then you will find out that it has "###". If i removed this three hash then extension template is working fine. But i'm not able to remove it because it is used by jQuery library for the purpose of number formatting.

Can you please provide the workaround for this issue?


Related issues

Related to TYPO3 Core - Bug #44270: wrong result in substituteMarkerArrayCachedClosedFranz Holzinger2013-01-02

Actions

Also available in: Atom PDF