Project

General

Profile

Actions

Bug #73668

closed

CE-Table: Header- and Footer-option

Added by André Stafast about 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Fluid Styled Content
Target version:
-
Start date:
2016-02-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello, I found a bug in CE-Table.

If I set „Table footer position“ and/or „Table header position (Top/Left)“ the output is still 0 for „table_header_position“ and „table_tfoot“.

Greets André

Actions #1

Updated by André Stafast about 8 years ago

Small Info:
In backend the options are stored in „tt_content.pi_flexform“, but not in „tt_content.table_header_position“, „tt_content.table_tfoot“

Actions #2

Updated by Dieter Porth about 8 years ago

The flexform-definitions is defined in a file, which is located in typo3\sysext\css_styled_content\Configuration\TCA\Overrides\tt_content.php:

\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addPiFlexFormValue('*', 'FILE:EXT:css_styled_content/flexform_ds.xml', 'table');

I have not installed the template of css_styled_content, but the flexform are used in the backend.
How can I override this definition with an own flexform-file?

Actions #3

Updated by GAYA La Nouvelle Agence about 8 years ago

The TCA definition in css_styled_content is applied if css_styled_content extension is enabled in extension manager, not by css_styled_content TS template.

If should disable this extension (if you use fluid_styled_content for exemple)

Actions #4

Updated by Riccardo De Contardi about 8 years ago

  • Status changed from New to Needs Feedback

Can you tell us more about how to reproduce your problem? Do you use Fluid Styled Content? Css Styled Content? Both?

(as suggested on the latest comment) do you have Css Styled Content enabled on extension manager, but no static template loaded for it?

Thank you

Actions #5

Updated by André Stafast about 8 years ago

Thanks!
I just needed to disable „Css Styled Content“ in extension manager.

Actions #6

Updated by Georg Ringer almost 8 years ago

  • Status changed from Needs Feedback to Resolved

seems to be solved, therfore I am closing the issue

Actions #7

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF