Bug #73742

Hook to inject js into UserSettingModule not working anymore

Added by Sebastian Michaelsen almost 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-02-29
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

With this commit (https://github.com/TYPO3/TYPO3.CMS/commit/48321468913086e803566af0688c8578af2829a3) the hook ['ext/setup/mod/index.php']['setupScriptHook'] stopped working because the getJavaScript() method is not called anymore. It was not documented that the hook is gone and the method is still there so I assume it was accidentally removed.


Related issues

Related to TYPO3 Core - Task #69886: Use ModuleTemplate API for ext:setup Closed 2015-09-16

History

#1 Updated by Georg Ringer almost 4 years ago

  • Is Regression changed from No to Yes

#2 Updated by Oliver Hader over 3 years ago

What's the impact, can it be solved differently to inject custom JavaScript into EXT:setup?

#3 Updated by Georg Ringer almost 2 years ago

  • Status changed from New to Closed

Check out \TYPO3\CMS\Rsaauth\Hook\UserSetupHook::getLoginScripts which calls the PageRenderer and loads a requireJS module. It might be that this was not possible when the issue has been created but at least in current version that works fine.

Also available in: Atom PDF