Bug #75331

Epic #72584: sysext:impexp

Impexp does not care about filemounts

Added by Benni Mack over 3 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Import/Export (T3D)
Target version:
Start date:
2016-03-31
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

The code inside ImportExport.php shows it clearly: There are checks to verify the folder access which checks against filemounts inside BasicFileFuntions which are empty all the time now, thus it always returns false.

Associated revisions

Revision 30d99021 (diff)
Added by Benni Mack about 3 years ago

[BUGFIX] Verify folder access for file mounts of BE users

The current implementation does not allow non-admins backend
users to import files as the folder access always returns false
due to the empty $mounts variable inside BasicFileFunc.

As FAL does the permission checks automatically, the logic
from BasicFileFunc is not needed anymore, and can be
accessed directly.

Resolves: #75331
Releases: master
Change-Id: I0211286cc6ae939229a0d7eb45adc89d1600d635
Reviewed-on: https://review.typo3.org/47454
Reviewed-by: Nicole Cordes <>
Reviewed-by: Markus Klein <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47454

#2 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47454

#3 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47454

#4 Updated by Gerrit Code Review over 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47454

#5 Updated by Daniel Goerz about 3 years ago

  • Sprint Focus set to Stabilization Sprint

#6 Updated by Benni Mack about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF