Bug #75436

Page delete button missing after deleting subpage

Added by Christian Weiske almost 2 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2016-04-07
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In the page tree, I've got a page with a subpage.
The page itself cannot be deleted because it has the subpage, thus the "Page actions" submenu does not contain the "Delete" menu entry.

After deleting the subpage, the "Delete" menu entry does still not show up.
Only after reloading the page tree with the reload button on the top makes the Delete button appear in the menu.

Steps to reproduce:

  1. Create page
  2. Create subpage
  3. Delete subpage
  4. Click the page icon in the tree, open the "Page Actions" submenu
  5. "Delete" is missing

2016-04-07 typo3 page actions no delete.png View (14.6 KB) Christian Weiske, 2016-04-07 10:47

Associated revisions

Revision 4c6ba8aa (diff)
Added by Gianluigi Martino 9 months ago

[BUGFIX] Reload page tree after deleting pages

After deleting a subpage the page tree doesn't reload so you don't have
the delete button in context menu from the parent page. With this bugfix
the page tree reloads after deleting pages and deleting parent pages is
possible again.

Change-Id: I9450261052ce07155fc2eff550b4547564dbf880
Resolves: #75436
Releases: 7.6
Reviewed-on: https://review.typo3.org/52700
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Tested-by: TYPO3com <>
Reviewed-by: Jan Helke <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48041

#2 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48041

#3 Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48041

#4 Updated by Gerrit Code Review 10 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48041

#5 Updated by Gerrit Code Review 10 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48041

#6 Updated by Gerrit Code Review 10 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48041

#7 Updated by Gerrit Code Review 10 months ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52700

#8 Updated by Riccardo De Contardi 10 months ago

This issue seems still valid only for 7.6.x; in Master is already fixed AFAICS (can someone confirm?)

The exact steps to reproduce it on 7.6.x are:

1) Create a page "Page"
2) create a subpage "Subpage"
3) IMPORTANT! refresh the tree
4) click on page icon of "Subpage" in pagetree> from the menu > delete the subpage "Subpage"
5) click on page icon of "Page" in pagetree > attempt to find the "delete" button > Missing :)

#9 Updated by Gerrit Code Review 9 months ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52700

#10 Updated by Gianluigi Martino 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF