Project

General

Profile

Actions

Bug #75457

closed

indexed_search not compatible with PHP7

Added by Erik de K almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-04-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

After updating to PHP7 the following error occured after using search:

PHP Warning: Declaration of TYPO3\CMS\IndexedSearch\Controller\SearchFormController::pi_list_browseresults($showResultCount = true, $addString = '', $addPart = '', $freeIndexUid = -1) should be compatible with TYPO3\CMS\Frontend\Plugin\AbstractPlugin::pi_list_browseresults($showResultCount = 1, $tableParams = '', $wrapArr = Array, $pointerName = 'pointer', $hscText = true, $forceOutput = false) in /html/typo3/typo3_src-7.6.2/typo3/sysext/indexed_search/Classes/Controller/SearchFormController.php line 2504

Downgrading to PHP5.6 fixed the issue for now.

Attached is the detailed TYPO3 Exception


Files

TYPO3 Exception.htm (18 KB) TYPO3 Exception.htm Erik de K, 2016-04-08 11:54

Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #72931: Indexed search with strict standardsClosedTymoteusz Motylewski2016-01-25

Actions
Actions #1

Updated by Christian Kuhn almost 8 years ago

  • Status changed from New to Closed

this was fixed with #72931 a couple of days ago.

Actions

Also available in: Atom PDF