Bug #75882

Epic #72584: sysext:impexp

t3d import gives exception: File "" does not exist

Added by Vincent Mans about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Import/Export (T3D)
Start date:
2016-04-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Tried several times with different export settings. Excluding all files, for instance, to be sure in case of FAL issues. And only tt_content on this page.

The source comes from 4.7.1 and the target is 7.6.5.

The t3d file is there where it's supposed to be: fileadmin/user_upload/_temp_/importexport/T3D__2016-04-23_12-37-z.t3d

Here is a part of the message:
-----

Uncaught TYPO3 Exception
#1319552745: File "" does not exist. (More information)

InvalidArgumentException thrown in file
/home/sites/clients/client19/web93/typo3_src_active/typo3/sysext/core/Classes/Resource/ResourceStorage.php in line 1157.

15 TYPO3\CMS\Core\Resource\ResourceStorage::addFile(NULL, TYPO3\CMS\Core\Resource\Folder, "", "rename")

/home/sites/clients/client19/web93/typo3_src_active/typo3/sysext/core/Classes/Resource/Folder.php:
00282: {
00283: $fileName = $fileName ? $fileName : PathUtility::basename($localFilePath);
00284: return $this->storage->addFile($localFilePath, $this, $fileName, $conflictMode);
00285: }
00286:

14 TYPO3\CMS\Core\Resource\Folder::addFile(NULL, NULL, "rename")

/home/sites/clients/client19/web93/typo3_src_active/typo3/sysext/impexp/Classes/Import.php:
01136: if ($fileObject === null) {
01137: try {
01138: $fileObject = $this->legacyImportFolder->addFile($tempFile, $fileName, DuplicationBehavior::RENAME);
01139: } catch (Exception $e) {
01140: $this->error('Error: no file could be added to the storage for file name' . $this->alternativeFileName[$tempFile]);

#1

Updated by Vincent Mans about 5 years ago

It seems the import is done, anyway. But with the error message.

#2

Updated by Riccardo De Contardi almost 5 years ago

  • Category set to Import/Export (T3D)
#3

Updated by Benni Mack almost 5 years ago

  • Target version changed from 7.6.5 to Candidate for patchlevel
#4

Updated by Riccardo De Contardi over 3 years ago

  • Parent task set to #72584
#5

Updated by Benni Mack about 1 year ago

  • Status changed from New to Closed

seems like the file was not included in the original export. This is because the impexp is only partly compatible for TYPO3 v4 to v7, and completely dropped this functionality in TYPO3 v9.

Also available in: Atom PDF